Devices Do Not Appear On Windows 11 Launchpad

Created: Modified: Knowledge Base

Symptom

In some cases, Imprivata has seen Windows 11 systems that do not have any driver for Apple devices installed. On these systems, Device Manager will show phones under the “Portable Devices” category but not in the Universal Serial Bus categories.

  • Devices will appear as disconnected from the Launchpad
  • Smart Hub LEDs next to the device will be off
  • In Device Manager, devices will display a “!” warning.
Root cause

The “Apple Mobile Device USB Device” driver versions 423.36.0.0 and 486.0.0.0 may crash under use. These versions are installed automatically by Microsoft’s Windows update system.

Remediation

Imprivata recommends uninstalling Windows Update driver and then installing the stable Apple-supplied driver on affected systems.

Uninstall the Windows Update Driver
  1. Use the Start menu to search for Advanced System Settings.
  2. In the control panel, select the Hardware tab and open Device Installation Settings. Select No for the automatically download setting and Save Changes.
  3. Open PowerShell from the Start menu. Ensure that you select Run as Administrator.
  4. Paste the following code snippet and press Enter.
Get-WindowsDriver -Online | ForEach-Object -Process {
if (
$_.ProviderName -ne "Apple, Inc." -or
$_.ClassName -ne "USBDevice" -or
(Split-Path -Leaf -Path $_.OriginalFileName) -ne "appleusb.inf"
) {
return;
}
$oem_name = $_.Driver
Write-Output -Object "Uninstalling Apple Windows Update driver version $($_.Version)"
Start-Process -FilePath "pnputil.exe" -ArgumentList @("/delete-driver", $oem_name, "/uninstall") -NoNewWindow -Wait
}
  1. If the undesired driver is found, it will be uninstalled. The system must be restarted for changes to take effect.
    After restarting, be sure to verify that the installed driver has changed to the desired version.
  2. From Add & Remove Programs, uninstall all Apple software from the PC, including iTunes, Bonjour, Apple Software Update, Apple Mobile Device, and Apple Application Support.
Install the Apple Supplied Driver
  1. Download the latest version of iTunes from this link and extract the AppleMobileDeviceSupport64.msi with a tool such as 7-Zip.
  2. Open a command prompt and install MobileDevice by running the following command.
    NOTE: You must include the “INSTALL_DRIVERS=1” flag to force the driver installation.
msiexec /i AppleMobileDeviceSupport64.msi INSTALL_DRIVERS=1
  1. Verify that the “Drivers” folder is present C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers.
  2. Restart the PC.
  3. In Device Manager, validate the driver version listed now listed as 6.0.9999.69

NOTE: It may be necessary to uninstall the Apple Mobile Device Support software before reinstalling it, as upgrade installs do not respect the INSTALL_DRIVERS=1 flag.